Prestashop de localhost a producción…

Problema típico al mover Prestashop 1.4 a producción

Me he encontrado un cambio un poco tonto en la versión 1.4.0.17 de Prestashop que me ha llevado de cabeza. El problema ha surgido al pasar de localhost a producción, es decir, a la web.

La tienda se mostraba correctamente, pero cuando hacia click sobre un producto, o categoría, o cualquier otro tipo de enlace, me salía una página de error 404. Al mirar donde apuntaba el enlace, me di cuenta que en lugar de hacerlo sobre http://www.midominio.com, lo hacía sobre http://localhost/ . Para arreglar esto hay dos soluciones posibles.

  • Entrar en el phpmyadmin y en la tabla PS_CONFIG, en el registro PS_SHOP_DOMAIN escribir la dirección web de tu página (veréis que antes de modificar apunta a localhost).
Otra opción más sencilla en prestashop 1.4 es ir a al Back Office (BO) de la tienda que habéis colgado en internet, y en Preferencias -> SEO, donde pone “Nombre de dominio”,   escribir http://www.dominiovuestratienda.extension.
 
Robado de http://ocio.hairago.com/
 
Anuncios

4 comentarios en “Prestashop de localhost a producción…

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s